Microsoft Teams and Join Link problem

I’ve recently upgraded Microsft Teams to version 1.4.00.4855 (I run it on openSUSE Linux but I think this problem can be related to the rpm build and maybe even the deb) basically the external Join Invite by URL stopped working.

Digging around in the browser the content-type: "msteams" it’s opened by the lanucher "/usr/bin/teams" luckily it’s a simple shell script, apparently they added some switch messing up the URL variable.

Following the explanation, I’ve just downloaded the rpm and unpacked it:

https://packages.microsoft.com/yumrepos/ms-teams/teams-1.3.00.958-1.x86_64.rpm 
https://packages.microsoft.com/yumrepos/ms-teams/teams-1.4.00.4855-1.x86_64.rpm
rpm2cpio teams-xxxx.x86_64.rpm | cpio -idmv

And then do some diff:

leo@thinkleo5:~/dev/teams> diff 1.3/usr/bin/teams 1.4/usr/bin/teams
11c11
< nohup "$TEAMS_PATH" "$@" > "$TEAMS_LOGS/teams-startup.log" 2>&1 &
---
> nohup "$TEAMS_PATH" --disable-namespace-sandbox --disable-setuid-sandbox "$@" > "$TEAMS_LOGS/teams-startup.log" 2>&1 &
leo@thinkleo5:~/dev/teams>

Teams still run but the URL joins are ignored, you can fix editing the "/usr/bin/teams" the line 11 of the launcher.

From:

nohup "$TEAMS_PATH" --disable-namespace-sandbox --disable-setuid-sandbox "$@" > "$TEAMS_LOGS/teams-startup.log" 2>&1 &

To:

nohup "$TEAMS_PATH" "$@" --disable-namespace-sandbox --disable-setuid-sandbox > "$TEAMS_LOGS/teams-startup.log" 2>&1 &

Leave a Comment

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.